Haven't Been Able To Post Anything Since Relaunch

Discussion in 'Support' started by Ivory_Soul, Dec 26, 2017.

  1. Ivory_Soul

    Ivory_Soul Highly Motivated Test Subject

    Nov 15, 2005
    Likes Received:
    So, I have finally been able to login to the forum since GR launched the new site. I tried for weeks to no avail disabling ad-blockers, trying new browsers, and even on different devices. I couldn't even click on the page that shows the admins emails which was insane. So finally, after all this time, I can now post on the forums, but does anyone know what caused this? I would either click the login and the page would never load, or the page wouldn't accept my credentials. It was just an endless loop of clicking submit. Same goes for being able to comment on articles, I would click the "GameRevolution" button and nothing would ever happen. I would even try logging in with other platforms and still nothing. It's so frustrating as I've never been unable to use a site for this long before.

    I also have to mention the site is nearly just as slow as the old site bogging down my browser. I also can't change my profile picture, as clicking it does nothing when I try to update it. Same goes for Discuss. I used the "GR Forum" login method as any others give me an endless login loop. However, it has no profile picture.

    Despite all that, it's good to be back.

    UPDATE: Can't login to comment again. I click on login with GameRevolution or GameRevolution Forum and nothing happens when I click on it. This site seriously needs someone working on it who knows what they're doing.
    Last edited: Jan 1, 2018
  2. Master_Craig

    Master_Craig Forum Moderator
    Staff Member

    Jul 2, 2006
    Likes Received:
    I've had similar issues. My Discus profile picture is blank and my Discus profile is essentially blank too. I also find that some of my comments on Discus get deleted over time, and I'm not actually doing anything to cause deletion (profanity etc.)
  3. Starling

    Starling Novice

    Apr 3, 2013
    Likes Received:
    For over a week, his issue has persisted for my GR disqus account. Whenever I post something, it get's auto-flagged for moderation and then is deleted, never to be seen again.

    The worst thing is, that I can't log in with my actual Disqus account either because if I log out from disqus with my GR disqus account, it automatically logs back in with GR account.

    So yeah, can't post anything into the comments anymore. My rant about how MGR is more Metal Gear than even Metal Gear Solid V, my helpful tip about how to navigate in Subnautica, all gone.

    EDIT: I have solved my issues by deleting the cookies in my browser. Didn't have to clear all of my cookies either, just the Gamerevolution ones.

    Do note that this will log you out of the site and will reset your options such as theme options but it's no big deal... provided you still remember you credentials.
    Last edited: Jan 26, 2018
  4. Jason Faulkner

    Jason Faulkner Senior Editor
    Staff Member

    Oct 15, 2017
    Likes Received:
    We've had some technical issues with the forums lately. I was finally able to get my account activated today, and we're getting the errors with logins and email confirmations fixed. If anyone in the thread has anymore issues, PM Paul or myself and we'll get it straightened out.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice